Technische Dokumentation der Freifunk Installation in Mellnau

Auf dieser Seite sind die technischen Zusammenhänge und Besonderheiten des Freifunk Netzes in Mellnau, dem Rosphetal und Wetter dokumentiert. Die Seite wird gepflegt von Andreas W. Ditze. Das Freifunk-Netz selbst wird betreut von Andreas W. Ditze, Jürgen Krieg und weiteren Aktiven des Freifunk Nordhessen e.V. und Freunden des Freifunks.

Stand dieser Dokumentation ist: 28. Juli 2021

Das Freifunk Netz in Mellnau

Übersichtskarte Freifunk Mellnau, 4/2020

Finanzierung und Gründungsgeschichte des Freifunknetzes sind an anderer Stelle bereits dokumentiert. Einen detaillierten Rückblick auf die Grundsteinlegung des Netzes findet sich hier.

Ziel des Netzes war und ist, die öffentlichen Plätze in Mellnau mit WLAN zu versorgen. Grundschule, Dorfgemeinschaftshaus, Kirche, Burg, Kuckuckshütte, Bolzplatz – an vielen Stellen hat das bereits geklappt. Aufgrund von Material- und Geldspenden können im Dorf noch weitere Accesspoints errichtet werden.

Freifunk oder Digitale Dorflinde?

Die Digitale Dorflinde erlaubt den Zugang ins Netz – aber nur mit Vorschaltseite.

Auch in Mellnau gibt es mittlerweile eine(!) digitale Dorflinde. Gemeint ist damit der vom Land Hessen öffentlich geförderte Hotspot. Er befindet sich am Ortsvorsteherbüro und ist leider nicht mit dem Freifunk-Netz kompatibel. Die digitale Dorflinde ist technisch so gestaltet, dass man vor der Nutzung zunächst den Anbieter-AGB zustimmen muss. Was banal klingt, bringt in der Praxis Probleme mit sich. Erkennt ein Smartphone eine solche AGB-Vorschaltseite, blendet es sie ein und wartet auf eine Bestätigung – automatisch wird hier nichts bestätigt. Das ist nicht nur unkomfortabel, sondern auch hinderlich. Wer in einem Handy-Funkloch wohnt, könnte über ein offenes WLAN zumindest noch telefonieren, aber eben nur, wenn er auch eingeloggt ist. Hat man sich einmal bei Freifunk eingewählt, geschieht das danach automatisch. Die Dorflinde braucht regelmäßig den manuellen Login. Sensoren und Messgeräte können eine solche AGB-Sperre prinzipiell nicht überwinden, was bedeutet, dass Feinstaub- oder Temperatursensoren, Rasenmäherroboter des Bauhofs oder Füllstandsmesser an Containern von diesem Netz nicht profitieren.

Lange Rede, kurzer Sinn: es wäre absolut wünschenswert, wenn die Stadt Wetter nicht nur für die digitale Dorflinde sondern auch für Freifunk ihren Netzanschluss bereitstellen würde.

Freifunk im Rosphetal & Wetter

Ende 2020 wurde das Konzept vom Mellnauer Freifunknetz auf die Ortsteile Oberrosph, Unterrosphe und die Kernstadt Wetter ausgedehnt. Soweit die dortigen Accesspoints von freifunk@mellnau.de mitadministriert werden, werden sie auch hier entsprechend aufgeführt. Die technische Dokumentation gilt sinngemäß auch für diese Ortsteile.

Netzwerk Topologie

Das Netz in Mellnau besteht aus Knoten mit direkter Internetanbindung und aus Knoten, die per Funk-Mesh verbunden sind. In Mellnau wird besonderer Wert darauf gelegt, dass jeder Knoten auch mindestens einen Mesh-Partner hat.

Die Netze in Oberrosphe und Unterrosphe folgen dem Beispiel in Mellnau, sie sind jedoch aktuell noch ein ganzes Stück kleiner.

Knoten mit Internetanbindung

Die folgenden Knoten hängen direkt “am Netz” und bringen die Megabits in das Freifunk-Netzwerk.

  • FF-Mellnau-Grundschule-ERX1+2
  • FF-Mellnau-Backes-Hof-ERX
  • FF-Mellnau-Bolzplatz-ERX
  • FF-Mellnau-ERX-Kuckuckshuette
  • FF-Mellnau-Hoobs-Hof
  • FF-Mellnau-Owe-Feisels
  • FF-Mellnau-Schmeddaniels1+2
  • FF-Mellnau-Wanderparkplatz
  • FF-Mellnau-Wehn
  • FF-Oberrosphe-Pfarramt-ERX
  • FF-Unterrosphe-Goebelers1
  • FF-Unterrosphe-Schmeeds-Hof-ERX
  • FF-Unterrosphe-Stiftung-Rosphetal
  • FF-Wetter-Ärztehaus
  • FF-Wetter-Nienhaus-SPD-ERX

Solange das gesamte Netz – zumindest innerhalb der Ortsteile – miteinander verbunden ist, sollte die Konfiguration robust genug sein, dass notfalls der gesamte Datenverkehr aller Netzknoten über einen dieser Router abgewickelt werden kann. Besonders wichtig sind dabei die ERX-Router, da diese erheblich leistungsfähiger sind als die normalen Accesspoints.

Hardware

Um die Pflege und die allgemeine Handhabung des Netzes zu erleichtern, wird insbesondere an den zentralen Stellen einheitliche Hardware verwendet. Wir folgen damit auch den Erfahrungen und Empfehlungen unseres Freifunk-Vereins.

  • Für die WLAN-Accesspoints: Ubiquiti Unifi AP AC Pro
  • Für Richtfunk: Ubiquiti Nanostation 5AC Loco, Powerbeam 5 AC
  • Für die Router / Offloader: Ubiquiti Edgerouter X (kurz: ERX)

Software

  • Auf den Richtfunkgeräten kommt die Hersteller-Firmware von Ubiquiti zum Einsatz.
  • Auf den übrigen Freifunk-Knoten wird die Router-Software Gluon in der Konfiguration von Freifunk Nordhessen, Community-Bereich Burgwald, installiert.
  • Auf jedem Freifunk-Knoten ist ein Zertifikat für den Login hinterlegt.
  • Auf den Geräten mit Hersteller-Firmware ist ein Passwort gesetzt.
  • Zertifikat und Passworte liegen für alle Fälle bei Familie Ditze feuerfest verstaut auf einem USB Stick.

Freifunk Einrichtung eines Ubiquiti Unifi AP AC Pro

  • Setze die statische IP-Adresse 192.168.1.10 auf deinen PC/Laptop
  • Verbinde den Laptop mit dem LAN-Port des PoE Injektors des Accesspoints
  • Verbinde den Accesspoint mit dem PoE Injektor
  • Der Accesspoint ist in der Stock-Firmware-Konfiguration unter 192.168.1.20 mit den Zugangsdaten ubnt / ubnt zu erreichen
  • Führe zuerst ein Downgrade des Accesspoints durch
  • Die Firmware 3.7.58 hier herunterladen
  • Die Datei umbenennen in fwupdate.bin
  • Die soeben umbenannte Datei per scp auf den Accesspoint kopieren. Dann auf dem Accesspoint einloggen und den Downgrade starten.
# copy firmware to AP
scp fwupdate.bin ubnt@192.168.1.20:/tmp/

# login / use password ubnt
ssh -l ubnt 192.168.1.20

# start firmware downgrade (stock)
syswrapper.sh upgrade2 &

Nach dem letzten Kommando dauert es einen Moment, der Accesspoint bootet neu und man hat die alte Firmware am Start – mit der man anschließend das Gluon-Image aufspielen kann.

  • Als nächstes wird das Gluon-Image (aktuell 1.0.3) heruntergeladen…
  • …und erneut per SCP auf den Accesspoint kopiert.
  • Achtung: das verlinkte Image passt nur auf Unifi AP AC Pro Geräte (Generation 1+2). Hat man ein anderes Unifi-Gerät, muss der Auswahlassistent bemüht werden.
  • Nachdem das Image erfolgreich hochgeladen wurde, wird der aktuelle Kernel des Accesspoints überschrieben und der Reservekernel gelöscht.
# copy gluon firmware to AP
scp gluon-ff_fkb_frankenberg-1.0.3-ubiquiti-unifi-ac-pro-sysupgrade.bin ubnt@192.168.1.20:/tmp/

# login / use password ubnt
ssh -l ubnt 192.168.1.20

# start firmware upgrade (gluon)
mtd write /tmp/gluon-ff_fkb_frankenberg-1.0.3-ubiquiti-unifi-ac-pro-sysupgrade.bin kernel0

# erase 2nd kernel
mtd erase kernel1
  • An dieser Stelle wird noch eine kleine Sicherheitsüberprüfung durchgeführt. Damit der Accesspoint wirklich von Kernel 0 startet, muss das Bootselector-Flag gesetzt werden. Prüfe dazu, ob mtd4 die Partition bs ist.
cat /proc/mtd
  • Das Kommando sollte eine Reihe von Zahlen ausgeben:
dev: size erasesize name
mtd0: 00060000 00010000 "u-boot"
mtd1: 00010000 00010000 "u-boot-env"
mtd2: 00790000 00010000 "kernel0"
mtd3: 00790000 00010000 "kernel1"
mtd4: 00020000 00010000 "bs"
mtd5: 00040000 00010000 "cfg"
mtd6: 00010000 00010000 "EEPROM"
  • Entscheidend ist die Linie mtd4. Wenn dort “bs” steht, ist alles in Ordnung. Steht das bs nicht hinter mtd4, sondern bspw. hinter mtd7, ist das folgende Kommando auf dem Accesspoint entsprechend anzupassen (7 statt 4).
dd if=/dev/zero bs=1 count=1 of=/dev/mtd4
  • Ist das erledigt, muss der Accesspoint rebootet werden.
  • Anschließend ist der Accesspoint unter http://192.168.1.1 erreichbar und kann nach Standard per Webinterface eingerichtet werden.
  • Unter Erweiterte Einstellungen wird der Freifunk-Mellnau-Pubkey hinterlegt.
ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAACAQDu6hqF6XZZchwCsbMn7qG5Wpf/ti2TpFhaWn6MBRLWa7QgcoeJVQ6g0RsvHAOx3sEHFZqw6kChodahixcdyMjPVU3iiuiRovyDwsJbRO9VYpY32Dwmufc2sNsAUR8AkA6bPpd7WhP3d/XDgVBrImqDwGUVK0DpMh/BBgEEnZS+/a5cMrH9nvKfQm0pR8DUnT+xusvr7FMR9PJ7dSXAdfVBVqqtE+rXbgYilAzkexEXarRwERT/fJPRvTETXOk2xkvR0OhHbqp+J0OzGPOnIp6SXCoh9vTe00IewXu+hPN8h3iZG57Avy52cblRniY+x3c0JbSaRq/KVMgLuZwl0pk4xusMrmeWOICYPdY1+cv7eBEP/HzrjRwfvQluPthqP/+eihdbBOUoqY36j8LerQ/hUlNQSvxM8hWGU6CASQH1rlA8xjhhWlqcDP9eoudPr2t5o3JaZGNpx3KQb1nWyrtMn3DvuxWMyPcWd7oOUkrB0yWd6HMCVq6Wzkj89pc6xslvtkJuK+QJRwQBoAfhLhkVv38Bq5k0t1len1MzNrNZPK8e7KwhdG1cusZEa0DFbfMii4nA/EWM8RCxxBDAcPMzAOPk3D60WoOgE1yai6KCTD0sYG5YcUC2cpz7To58glK9YejEtnvcAJ6YK/kVeaVCBBSzxKrVnrZ+AL43LyCB/Q== freifunk@mellnau.de
  • Die E-Mailadresse freifunk@mellnau.de wird als Kontakt hinterlegt, ggf. wird auch eine Knotenposition eingetragen.
  • Als Domäne wird “Burgwald” ausgewählt.
  • Anschließend einmal Speichern & Neustarten
  • Danach per SSH den neuen Accesspoint testen
ssh -l root -i freifunk_key <$IP6-Adresse_des_Accesspoints>
  • Zu guter letzt wird dann noch die Dome-Beleuchtung des Accesspoints abgeschaltet
  • Dazu die Datei /etc/config/system öffnen und folgendes eintragen
config 'led'
	option 'sysfs' 'ubnt:white:dome'
	option 'default' 0
  • Danach den Accesspoint noch einmal rebooten und der Vorgang der Grundeinrichtung ist abgeschlossen.
  • Diese Dokumentation folgt den HowTos von Freifunk Greiswald und dem Hackspace Marburg – herzlichen Dank. Auf den verlinkten Seiten findet sich auch Hilfestellung für den Fall, dass ein ge-brickter Accesspoint per TFTP gerettet werden will.

Spezifische Anpassungen in der Router-Software

  • Auf Wunsch ist es möglich, ausgewählte Endgeräte auf einem Accesspoint zu sperren. Typische Anwendungsfälle dafür sind, wenn man bspw. zu Hause nicht automatisch ins benachbarte Freifunk-Netz eingeloggt werden will. Denkbar ist auch, die schuleigenen Tablets damit aus den Freifunk-Netz um die Schule herum auszusperren.
  • An besonders exponierten Standorten wird die Sendeleistung der Geräte deutlich gedrosselt. Ansonsten kann es passieren, dass ein Smartphone zwar anzeigt, dass ein Freifunk-Signal vorhanden ist, das Smartphone kann sich aber aufgrund seiner kleinen Antenne und des ungünstigeren Standorts nicht mit dem Accesspoint verbinden. Von dieser Anpassung sind die Accesspoints Kirchturm, Burg2 und Kuckuckshütte betroffen.

Code: Namen des Freifunk-Knotens ändern

Um die aktiven als auch die vorrätigen Geräte gut voneinander unterscheiden zu können, werden die Nodes nach folgendem System beschriftet. Aktive Nodes heißen “FF-Mellnau-<Location>-<Details>”, z.B. FF-Mellnau-Schmiede.  Geräte, die zwar schon vorhanden aber noch nicht im Einsatz sind, heißen “FF-Mellnau-Reserve#”, wobei # für die Gerätenummer steht. Die Nummerierung ist fortlaufend und wird von Andreas W. Ditze gepflegt, soweit die Accesspoints zentral angeschafft bzw. betreut werden.

Der Code zur Änderung des Namens über die Gluon-Konsole lautet

pretty-hostname FF-Mellnau-xyz

Code: Reduzierung der Sendeleistung

An besonders hohen Standorten bzw. Standorten mit hoher Funkreichweite muss die Sendeleistung der Accesspoints gedrosselt werden. Hintergrund dabei ist, dass der Accesspoint aufgrund seines überragenden Standorts von vielen Geräten gehört werden kann, er selbst bekommt aber von den Clients längst nicht so viel mit, da diese mit kleineren Antennen und von ungünstigeren Orten aus senden. Würde die Sendeleistung nicht reduziert, entsteht beim Anwender der Eindruck, dass er zwar volle WLAN-Signalstärke hat, sich aber dennoch nicht mit dem Freifunknetz verbinden kann.

# show transmit power
iwinfo phy0 txpower

# reduce transmit power
iw phy0 set txpower fixed 1200

Code: Aktivierung des Outdoor Modus

Accesspoints die nicht innerhalb geschlossener Räume betrieben werden, sollten in den Outdoor-Modus versetzt werden. Dadurch kann das Meshing auf 5 GHz unterbunden bzw. reguliert werden.

uci set gluon.wireless.outdoor='1'
uci commit
gluon-reconfigure
reboot

Aktuell wirft gluon-reconfigure noch eine Fehlermeldung, weil die site.conf Datei in der Standardinstallation nicht enthalten ist. Standardmäßig wird in dem Fall das Meshing auf 5 GHz unterbunden, was das gewünschte Verhalten ist.

Code: Sperrung spezifischer MAC Adressen auf einem Knoten

Wie auch schon bei der SSID gilt, dass die Sperrungen unter /etc/rc.local lokale hinterlegt werden sollten, damit ein Autoupdate die Sperrliste nicht versehentlich löscht. Auch hier gilt die bekannte Einschränkung: beim ersten Reboot nach einem Update ist die Sperrliste nicht aktiv. Beim nächsten Neustart nach ca. 24h sind die Änderungen wieder da. Bisher kommt dieser Fall ca. 1-2 Mal pro Jahr vor.

Im folgenden Beispiel werden auf einem Node zwei spezifische Geräte auf beiden Bändern (Radio0, Radio1) gesperrt:

# delete old denylist
uci delete wireless.client_radio0.macfilter
uci delete wireless.client_radio1.macfilter

# create new denylist
uci set wireless.client_radio0.macfilter='deny'
uci add_list wireless.client_radio0.maclist=50:aa:bb:cc:dd:ee
uci add_list wireless.client_radio0.maclist=58:xx:yy:zz:11:22
uci set wireless.client_radio1.macfilter='deny'
uci add_list wireless.client_radio1.maclist=50:aa:bb:cc:dd:ee
uci add_list wireless.client_radio1.maclist=58:xx:yy:zz:11:22
uci commit wireless

Code: zeitgesteuertes aktivieren/deaktiveren des WLAN

Mitunter mag es an einer Location notwenig sein, dass WLAN zu bestimmten Zeiten zu deaktiveren. Dazu bedienen wir uns codemäßig bei den Freund:innen von Freifunk Gera Greiz.

Mit diesen Befehlen wird das WLAN (2,4 + 5 GHz) deaktiviert:

uci set wireless.client_radio0.disabled=1;wifi
uci set wireless.client_radio1.disabled=1;wifi

So wird es wieder aktiviert:

uci set wireless.client_radio0.disabled=0;wifi
uci set wireless.client_radio1.disabled=0;wifi

Fügt man diese Befehle nun in die lokale Crontab ein, wird daraus eine Zeitschaltuhr fürs WLAN. Trotz der Abschaltung des Client-WLAN bleibt das Gerät für Mesh und Updates erreichbar.

Deaktiviere das WLAN jeden Tag ab 20 Uhr:

crontab -e
0 20 * * * uci set wireless.client_radio0.disabled=1
0 20 * * * uci set wireless.client_radio1.disabled=1
1 20 * * * wifi

Und um das WLAN morgens um 6 Uhr wieder zu aktivieren werden diese Zeilen in die Crontab eingetragen:

0 6 * * * uci set wireless.client_radio0.disabled=0
0 6 * * * uci set wireless.client_radio1.disabled=0
1 6 * * * wifi

Da es problematisch ist, über die Crontab zur selben Zeit zwei identische Config-Änderungen anzuwenden, werden hier zunächst mal nur die beiden Radiobänder aktiviert bzw. deaktiviert und erst eine Minute später mit mit dem Befehl “wifi” die Änderungen aktiviert. Würde man wifi parallel laufen lassen, könnten sich beide “wifi” Prozesse ins Gehege kommen.

Freifunk Einrichtung eines Ubiquiti Edgerouter X

Beim Ubiquiti Edgerouter X lässt sich die Freifunk Frankenberg Firmware recht entspannt über das Webfrontend der Stock-Firmware des Geräts aufspielen. Im Detail haben das die freifunkenden Freund*innen aus Bremen dokumentiert, die wir hier gerne verlinken.

Die passende Frankenberger Firmware für den Edgerouter X bzw. den Edgerouter X SFP findet sich in unserem Download-Bereich.

Code: VLAN-Aufsplittung an den ERX Routern

Darstellung eines Routers mit BeschriftungStandardmäßig arbeiten die ERX Router mit Freifunk-Firmware wie ein normaler Router (1x WAN Port, Rest LAN) mit angeschlossenem Switch, d.h., alle Teilnehmer sehen sich auf dem LAN. In der Freifunk-Karte führt dies dazu, dass auf einmal zwischen allen angeschlossenen Nodes Verbindungen sichtbar werden, obwohl sich die Nodes in der Praxis gar nicht direkt erreichen können. Um dieses unerwünschte Verhalten zu beheben, muss die Konfiguration der Geräte Grundschule-ERX und Burg-ERX folgendermaßen angepasst werden.

Der Mellnauer Standard beim ERX ist, Port 1 für WAN zu lassen, die Ports 2+3 für Mesh on LAN (d.h., Batman). Port 4 liefert eine normale Client-IP und Port 5 liefert eine Client-IP mit dem VLAN-Tag “5”. Letzteres wird benötigt, da unsere Ubiquiti Nanostations standardmäßig über VLAN 5 ihr Management-Interface erreichbar haben.

Disclaimer: mit den Ports 4 und 5 muss man vorsichtig sein. Die Ports werden immer dann benötigt, wenn bspw. Unifi Accesspoints mit Stock-Firmware bedient werden sollen. Oder Richtfunkgeräte, die darüber ihre Management-IP erhalten. Wer hier jedoch sein Apple TV, seinen Drucker oder gar den Heimserver anschließt, teilt diese Ressource mit der gesamten Freifunk-Domäne Burgwald. Kann man machen, ist aber nicht empfohlen.

Nun zur Konfiguration: als erstes müssen ein paar Zeilen aus der Datei /etc/config/network entfernt werden:

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 2 3 4 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

Nur keine Zurückhaltung – die müssen wirklich alle weg. Wir fügen gleich neue Einträge hinzu.

Ergänze in der Datei /etc/config/network

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'
config switch_vlan
option device 'switch0'
option vlan '3'
option ports '2 4 6t'
config switch_vlan
option device 'switch0'
option vlan '4'
option ports '3 6t'
config switch_vlan
option device 'switch0'
option vlan '5'
option ports '4t 6t'

Bei der Verkabelung ist darauf zu achten, dass der Netzzugang auf eth0 (Port 1 von links) angeschlossen wird.

Tipp: Achte darauf, dass in der letzten Zeile wirklich “4t 6t” steht. 4t bedeutet, dass auf dem fünften Port ein getaggtes VLAN mit der Nummer 5 ausgegeben wird. Neben dem getaggten VLAN 5 ist auf diesen Port auch Mesh on LAN verfügbar, was durch den Eintrag “option ports ‘2 4 6t'” realisiert wird. Das MoL, was auf Port 2 ist, wird standardmäßig auf Port 4 mit ausgegeben. Im Ergebnis kann man so eine Nanostation 5AC Loco über einen Port sowohl mit Management-LAN als auch Mesh on LAN erreichen.

Anschließend diese Befehle hier einmal durchlaufen lassen:

uci set network.mesh_lan=interface
uci set network.mesh_lan.igmp_snooping='0'
uci set network.mesh_lan.ifname='eth0.1'
uci set network.mesh_lan.index='4'
uci set network.mesh_lan.proto='gluon_wired'
uci set network.mesh_lan.transitive='1'
uci set network.mesh_lan.macaddr=$(echo 1$(uci show network.bat0.macaddr)|md5sum|sed 's/^\(..\)\(..\)\(..\)\(..\)\(..\).*$/02:\1:\2:\3:\4:\5/')
uci set network.mesh_lan.disabled='0'

uci set network.mesh_lan2=interface
uci set network.mesh_lan2.igmp_snooping='0'
uci set network.mesh_lan2.ifname='eth0.3'
uci set network.mesh_lan2.index='4'
uci set network.mesh_lan2.proto='gluon_wired'
uci set network.mesh_lan2.transitive='1'
uci set network.mesh_lan2.macaddr=$(echo 1$(uci show network.bat0.macaddr)|md5sum|sed 's/^\(..\)\(..\)\(..\)\(..\)\(..\).*$/02:\1:\2:\3:\4:\5/')
uci set network.mesh_lan2.disabled='0'

uci set network.mesh_lan3=interface
uci set network.mesh_lan3.igmp_snooping='0'
uci set network.mesh_lan3.ifname='eth0.4'
uci set network.mesh_lan3.index='4'
uci set network.mesh_lan3.proto='gluon_wired'
uci set network.mesh_lan3.transitive='1'
uci set network.mesh_lan3.macaddr=$(echo 1$(uci show network.bat0.macaddr)|md5sum|sed 's/^\(..\)\(..\)\(..\)\(..\)\(..\).*$/02:\1:\2:\3:\4:\5/')
uci set network.mesh_lan3.disabled='1'

uci set network.mesh_lan4=interface
uci set network.mesh_lan4.igmp_snooping='0'
uci set network.mesh_lan4.ifname='eth0.5'
uci set network.mesh_lan4.index='4'
uci set network.mesh_lan4.proto='gluon_wired'
uci set network.mesh_lan4.transitive='1'
uci set network.mesh_lan4.macaddr=$(echo 1$(uci show network.bat0.macaddr)|md5sum|sed 's/^\(..\)\(..\)\(..\)\(..\)\(..\).*$/02:\1:\2:\3:\4:\5/')
uci set network.mesh_lan4.disabled='1'

uci set network.mesh_lan.ifname='eth0.1'
uci set network.mesh_lan2.ifname='eth0.3'
uci set network.mesh_lan3.ifname='eth0.4'
uci set network.mesh_lan4.ifname='eth0.5'

uci commit network

Die Konfiguration ist leider nicht update-fest und muss ggf. per Hand nachgesteuert werden. Sie könnte per rc.local updatefest gemacht werden, allerdings wirft Gluon in der 2019’er Version hierzu einen Fehler.

ToDo 7/2019: im Auge behalten.
Update 7/2021: bisher haben die Konfigurationsänderungen alle Auto-Updates überlebt.

Tipp 1: man muss die Befehle oben nicht alle per copy&paste übertragen. Man kann sie auch in eine Textdatei kopieren, die Datei ausführbar machen und dann einmal starten.

Tipp 2: Wem Tipp 1 zu hoch ist, der sollte dringend darüber nachdenken, von der händischen Konfiguration des ERX Abstand zu nehmen.

Wer bis hierher gekommen ist, hat jetzt am ERX die Ports aufgespalten und außerdem Port 2 und 3 für Mesh on LAN (MoL) aktiviert. Will man die Ports 4 und 5 ebenfalls für MoL nutzen, muss man folgenden Befehl in der Konsole eingeben:

uci set network.mesh_lan4.disabled='0'
uci set network.mesh_lan4.disabled='0'
uci commit network

Als nächstes kümmern wir uns darum, dass auf Port 4 und 5 nun auch IP-Adressen herausfallen.

Zur Erinnerung: Die Ubiquiti ERX Geräte werden in unserer Freifunk-Domäne als Offloader genutzt. Port eth0 ist der WAN-Port, eth1 bis eth4 sind LAN Ports. Gelegentlich braucht man auf einem LAN Port eine IP Adresse aus dem Freifunk-Netz. Dies ist z.B. dann hilfreich, wenn man Richtfunkgeräte oder (Unifi) Accesspoints mit Stockfirmware betreiben will. Dazu muss Mesh on LAN (MoL) auf einzelnen Ports deaktiviert werden. Das folgende Beispiel stammt von wiki.bremen.freifunk.net und wurde etwas angepasst.

Am Ende dieses Skripts hat ein ERX mit dem FF-FKB Default-Settings WAN auf Port 1, Mesh on LAN auf den Ports 2+3 sowie IP auf Port 4 und getaggte IP auf Port 5.

#uci set network.@switch_vlan[0].ports='1 6t' 

# define new interface
uci add_list network.client.ifname='eth0.4'
uci add_list network.client.ifname='eth0.5'
uci set network.brc_dev=device 

# use ifconfig eth0.2 to find out existing macaddr. 
# Add +1 and use it as new macaddr 
uci set network.brc_dev.macaddr='fc:ec:da:7f:28:eb' 
uci set network.brc_dev.name='eth0.3' 

uci commit network 
reboot

Sinnvollerweise würde man auch hier die rc.local nutzen wollen, um eine gewisse Updatefestigkeit zu erhalten. Leider führt die Übertragung direkt in die rc.local dazu, dass eth0.3 immer wieder neu angelegt wird – ziemlich unelegant.

ToDo: im Auge behalten

Im Ergebnis führt das dazu, dass das VLAN 5 getagged auf Port 5 ausgegeben wird. Würde man hier ein “ungetagtes” VLAN anlegen, würde es zu Loops am Router kommen – das will man nicht. Danach funktioniert das Management VLAN #5 auf der Nanostation.

Tipp: braucht man an der Nanostation kurzfristig ungetaggtes DHCP, macht man die obige Änderung am VLAN 3 rückgängig und legt VLAN 5 ungetaggt auf das Kabel. Merke: es darf immer nur ein ungetaggtes Signal auf einem Netzwerkkabel anliegen.

Wissenswertes zum Backbone Netz

So schön Mesh-on-LAN über Batman auch ist, wenn es um Datendurchsatz geht, braucht es eine separate Netzanbindung. Ist die vor Ort nicht gegeben, halten wir es hier so, dass das Netz per Richtfunk “eingeflogen” wird. Technisch gesehen handelt es sich dabei um Point-to-Point Verbindungen. Als Hardware werden hierfür jeweils paarweise Nanostation 5 AC Loco genutzt. Point-to-Multipoint-Verbindungen sind bisher noch nicht in gebrauch.

UNMS Controller

Tabellarische Darstellung der Backend Komponenten
Übersicht im UNMS Backend Controller

Das Management der Backbone-Komponenten erfolgt über den UNMS Controller von Freifunk Nordhessen. Der Login ist mit 2FA gesichert. Alle neuen Backbone-Komponenten, die hier verwaltet werden sollen, benötigen einen Key, über den sie sich beim Controller melden können. Der Key kann im Backend des Controllers heruntergeladen werden.

Grundsätzlich funktionieren die Backbone-Komponenten zwar auch ohne UNMS, mit dem Controller können die Geräte aber deutlich leichter verwaltet werden.

Tipp 1: wenn man selbst im Freifunk Netz eingeloggt ist, kann man über die private IPv4 Adresse der Komponenten diese auch direkt erreichen.

Tipp 2: weil Tipp 1 funktioniert, sollte man bei den Komponenten darauf achten, nicht(!) das Standardpasswort von Ubiquiti gesetzt zu lassen.

Unifi Controller

Übersicht Unifi Controller
Im Unifi Controller sind die besonders leistungsfähigen Geräte hinterlegt

Parallel zum UNMS gibt es außerdem noch den Unifi Controller von Freifunk Nordhessen. In diesem Controller sind die Unifi Accesspoints aufgelistet, die mit Stock-Firmware betrieben werden.

Der Vorteil der Stock-Firmware ist, dass sie deutlich performanter läuft als die Freifunk-Standardsoftware. Nachteilig ist, dass sie nicht mit dem Batman-Protokoll kompatibel sind und daher nicht offen vermesht werden können. Router mit Freifunk-Firmware können sich nicht direkt mit diesen Geräten verbinden. Unterm Strich heißt das, dass die Stock-Firmware-Geräte für die Netzstabilität nichts bringen, dafür aber zuverlässig große Mengen an Geräten (ca. 100 Endgeräte) mit Netz versorgen können – immer vorausgesetzt, die Internetanbindung gibt genügend her. Die Stock-Firmware-Geräte werden in der Burgwald-Domäne zwingend mit einem ERX-Router kombiniert, da nur so sichergestellt ist, dass der Datenverkehr der Stocks auch tatsächlich über das Freifunknetz ausgeleitet wird.

Richtfunk

Richtfunkgeräte und Router im Freifunknetz

Aktuell hängen alle Mellnauer Freifunk-Richtfunkstrecken “hinter” den Geräten Grundschule-ERX und Grundschule-ERX2.

  • Grundschule – DGH
  • Grundschule – Burg
  • Grundschule – Kirche

Bei den Richtfunkgeräten handelt sich um Ubiquiti Nanostation AC Loco, die mit originaler Herstellerfirmware auf 5 GHz betrieben werden. Die Richtfunkstrecken zur Burg und zur Kirche hängen direkt am ERX der Schule. Das Gerät zur Anbindung des DGHs ist per Powerline-Adapter an den ERX angebunden, wodurch leider etwas Performance verloren geht. Unterm Strich ist jedoch die Anbindung der Standorte (Kirche, Burg, DGH) per Richtfunk erheblich performanter als eine “normale” Verknüpfung per Freifunk-Mesh.

Bei der Konfiguration der Sendefrequenzen am Zugangspunkt (Accesspoint) ist das 5 GHz Frequenz für Deutschland zu beachten. Weitere Erläuterungen zu dem Frequenzraster finden sich auf wiki.freifunk-franken.de.

Frequenzraster 5 GHz
Frequenzraster für Indoor- und Outdoor Funkstellen

Wissenswertes zu den Freifunk-Standorten in Mellnau

Da die Geräteinstallation an einem Standort mitunter recht individuell sein kann, sind die wichtigsten Eigenheiten der Standorte hier kurz zusammengefasst.

Backes Hof

Richtfunkgerät mit Blick auf die Kirche in Mellnau
Freie Sicht auf den Kirchturm von Backes Hof

Bei Familie Balzer in der Alten Höhle sind zwei Accesspoints verbaut (Backes Hof 1, Backes Hof 2) sowie ein ERX. Am ERX hängt eine Nanostation (Gerät #70), die mit dem Kirchturm in Mellnau verbunden ist. Der ERX ist über DLAN angebunden, Backes Hof 2 hängt direkt am Router.

Die beiden Accesspoints laufen im Outdoor-Modus.

In der Theorie hätte von hier aus auch das Dorfgemeinschaftshaus seinen zweiten Uplink erhalten können. Jedoch: in der Fresnelzone stehen ein paar große Bäume. Backes Hof 1 verbindet sich je nach Wetterlage mal spontan mit dem DGH Parkplatz Gerät, eine richtige Richtfunkinstallation wurde bisher nicht ausprobiert.

ToDo: wenn mal sehr viel Zeit ist, testweise vom DGH aus schauen, ob man von dort Backes Hof “hört”.

Backhaus & Jugendclub

Hausfassade mit zwei WLAN-AntennenIm Backhaus sind zwei Geräte verbaut. FF-Mellnau-Jugendclub-ERX steuert den Richtfunk zur Burg und versorgt außerdem FF-Mellnau-Jugendclub. Der Jugendclub Accesspoint mesht wiederrum direkt mit Owe Feisels Hof, so dass das Gebäude Internet aus zwei unabhängigen Quellen bezieht.

Der ERX ist zusammen mit der Stromverteilung in der Theke im Jugendclub verbaut. Der Outdoor-Accesspoint ist stark genug, um auch die innenliegenden Räume des Jugendclubs zu erfassen. Das Gerät läuft im Outdoor-Modus.

Bolzplatz

Das Gerät FF-Mellnau-Bolzplatz steht auf dem Dachboden der Familie Ditze. Das Gerät FF-Mellnau-Bolzplatz-ERX steht im Keller. Anbindung: 50 Mbit/s. Der Uplink zur Kirche wird über eine Nanostation (Gerät #71) realisiert.

Burg

Antennenmast im Innenhof der Burg

Für das Freifunknetz kommt der Burg in Mellnau besondere Bedeutung zu. Von den allermeisten Stellen im Ort aus ist sie sichtbar, darüber hinaus ist sie ein beliebter Anlaufpunkt für Touristen. Außerdem wird sie für Veranstaltungen genutzt.

Für den Einstieg ins Freifunknetz sind auf der Burg die Accesspoints FF-Mellnau-Burg und FF-Mellnau-Burg2 installiert. Der erste Accesspoint ist im Gerätehäuschen auf dem Schaltschrank. Der zweite Accesspoint hängt am Gerätehäuschen oberhalb des Tors. FF-Mellnau-Burg läuft aus Performancegründen mit der Ubiquiti Stock-Firmware und erscheint deshalb nicht auf der Freifunkkarte.

FF-Mellnau-Burg2 ist von besonderer Bedeutung, da über ihn direkt die Geräte Grundschule 1, Kirchturm, Kuckuckshuette und Hoobs Hof sowie die Linkstrecken nach Unterrosphe und Wetter erreicht werden können. Selbst wenn die Richtfunkstrecke zwischen Grundschule und Burg einmal ausfallen sollte, ist hier noch ein Fallback sichergestellt.

Im Gerätehäuschen im Innehof der Burg finden sich zwei ERXe (Burg ERX und Dorfrechenzentrum) und zwei Accesspoints (Burg 1, Burg 2). Burg 1 läuft auf Stockfirmware, Burg 2 läuft auf Gluon im Outdoormodus. Die Offloader befinden sich im Schaltschrank.

Freies WLAN an der Burg

Obwohl die Burg selbst kein Internet hat, bezieht sie primär aus der Grundschule und als Reserve von Hoobs Hof und der Kuckuckshütte. Die Anbindung ist so stark, dass perspektivisch die Möglichkeit besteht, über den Sendemast im Innenhof das Netz per Richtfunk an andere Teile im Ort zu bringen (bspw. Backhaus). Ebenfalls perspektisch denkbar ist, über den Burgturm das Signal zum Sportplatz oder zu weiter entfernten Funktürmen (Sackpfeiffe?) zu bringen. Der Link zur Sackpfeiffe würde dann genutzt werden können, falls durch einen Kabelschaden das gesamte Internet im Ort nicht funktioniert.

Die technischen Komponenten auf der Burg befinden sich am Funkmast im Innenhof sowie im Gerätehäuschen des HVV. Im Gerätehäuschen wurde ein Schaltschrank installiert. Der Schlüssel ist u.a. beim HVV-Vorsitzenden.

Diehls Hof

Diehls Hof beherberte einmal einen Accesspoint, der jedoch nicht mehr aktiv ist. Stattdessen findet sich hier der Uplink zur Videoüberwachung der Burg Mellnau. Die Videoüberwachung ist nicht Teil des Freifunknetzes. Im Schaltschrank im Gerätehaus an der Burg teilt sich die Videotechnik einen Schaltschrank mit der Freifunk-Installation.

Dorfgemeinschaftshaus

Accesspoint am DGH Parkplatz

Im DGH Mellnau sind die Geräte FF-Mellnau-DGH-Parkplatz, FF-Mellnau-DGH-Saal und FF-Mellnau-Kegelbahn verbaut. Die Geräte auf dem Parkplatz und im Saal sind “Standardhardware”, für die Kegelbahn kommt ein Kleingerät vom Typ TP-Link WR941N zum Einsatz. Aufgrund der betagten Hardware ist das Gerät nicht im Autoupdate-Zyklus enthalten, da absehbar ist, dass neuere Versionen der Freifunk-Software auf ihm nicht mehr laufen werden.

Das DGH ist per Richtfunk mit der Schule verbunden. Es kommen ca. 20 Mbit/s im DGH an – limitierender Faktor ist auch hier wieder die Netzanbindung der Grundschule. Die Richtfunkstrecke endet im kleinen Saal und wird dort per PowerLine auf die drei Endgeräte verteilt. Auf der Karte wirkt es auch hier, wie schon bei der Schule, so, als wären die Accesspoints im DGH direkt mit der Grundschule verbunden. Tatsächlich gibt es aber nur eine Verbindung.

Das Gerät am Parkplatz wird aus der Küche heraus versorgt. Das Gerät im kleinen Saal hat seinen PoE-Injektor hinter einen Deckenplatte. Das Gerät in der Kegelbahn ist ein Desktop-Gerät und frei zugänglich auf dem Tresen.

Das Gerät am Parkplatz läuft im Outdoor-Modus.

Grundschule

Kirche, Burg und Grundschule – die zentralen Knoten im Mellnauer Freifunknetz

Die Grundschule ist der zentrale Freifunk-Hub in Mellnau. Von hier aus werden Burg, Kirche und DGH versorgt und die verschiedenen Netzinseln zusammengeschaltet. Herzlichen Dank an dieser Stelle an den Landkreis Marburg-Biedenkopf und insbesondere an die Abteilung Schule und Gebäudemanagement, die sich der Freifunk-Idee vom ersten Tag an sehr aufgeschlossen gegenüber zeigte.

Die zentralen Komponente in der Grundschule sind das Gerät FF-Mellnau-Grundschule-ERX und FF-Mellnau-Grundschule-ERX2. Es handelt sich hier um ERX Router, die das Schulnetz vom Freifunk-Netz trennen und den angebundenen Freifunkstationen als Offloader dient. Die Geräte stehen im Lehrerzimmer im obersten Stock. Von dort aus sind direkt die beiden Richtfunkstrecken zur Kirche und zur Burg angebunden.

Tabellendarstellung einer VLAN Konfiguration
Tabellarische Darstellung der VLAN Konfiguration

Besonders erwähnenwert ist hier noch der Ubiquiti Toughswitch, über den Mesh on LAN und IP an die Nanostation Locos Richtung DGH und Burg weitergegeben werden. Die MoL Pakete der ERXe gehen als “untagged packets” auf den Switch, das IP Netz wird mit dem Tag VLAN 100 bzw. VLAN 200 an die Nanostations weitergegeben. Durch die Kombination tagged/untagged kommen sowohl die Management-IPs zu den Richtfunkgeräten als auch die Batman-Meshes zur Burg bzw. DGH. Darüber hinaus dient der Toughswitch auch zur Energieversorgung der Nanostations Richtung Burg und Kirche.

Accesspoint FF-Mellnau-Grundschule2

Über eine PowerLine-Verbindung ist das Richtfunkgerät zur Schule angebunden, über eine separate PowerLine Verbindung ist Accesspoint FF-Mellnau-Grundschule2 erreichbar. Grundschule2 ist im obersten Stock gegenüber des Toilettenraums außen an der Gaube befestigt. Das Gerät läuft im Outdoor-Modus.

Die Powerline Verbindung in der Grundschule (Devolo 1200er) stürzt regelmäßig ab, ca. alle sechs Wochen. Um das Problem dauerhaft zu lösen, wurde jedes Adapterpaar mit einer Zeitschaltuhr ausgestattet. Ein harter Reset pro Tag für eine Minute löste bisher das Problem.

Der Accesspoint Grundschule 2 ist auch für die Schulscheune, das Gemeindearchiv und den Spielplatz von besonderer Bedeutung – alle diese Orte werden über dieses Gerät versorgt.

Hoobs Hof

Der Accesspoint FF-Mellnau-Hoobs-Hof hängt an der Scheune Richtung Burg. Das Gerät wird beherbergt von Familie Oeser. Die Anbindung an Netz liegt bei 25 Mbit/s. Das Gerät dient als Reserveuplink zur Burg, versorgt die Sitzecke am Heppenberg und dient auch als schnell erreichbaren Einstieg ins Freifunknetz für die Besucher des Ferienlagers. Es läuft im Outdoor-Modus.

Kirche

Das Gerät FF-Mellnau-Kirche steht hinter der Orgel und ist per PowerLine angebunden. Obwohl der Standort aus Funkwellensicht denkbar ungeeignet wird, ist das Gerät aber dennoch kontaktfreudig und funkt bis zur Grundschule. Es dient damit indirekt der Stabilisierung für den Fall, dass die Richtfunkanbindung einmal ausfallen sollte.

Kirchturm

Oberhalb des Glockenspiels ist ein Accesspoint installiert

Im Kirchturm ist ein großer Richtfunk-Hub zu finden. Es gibt Anbindungen in drei Richtungen:

  • Gerät 31 (Nanostation 5AC) zeigt Richtung Grundschule / Norden. Es ist eine PTMP Basis.
  • Gerät 87 (Nanostation 5AC) zeigt Richtung DGH und ist als PTMP-Client konfiguriert.
  • Gerät 88 (Nanostation 5AC) zeigt Richtung Wattenscheider Lager / Süden. Es ist eine PTMP Basis.

Daneben befindet sich der Accesspoint FF-Mellnau-Kirchturm. Per PowerLine-Switch ist das Gerät innerhalb der Kirche angebunden.

Der Kirchturm erhält per Richtfunk Internet von Backes Hof, dem Bolzplatz und der Schule sowie über Mesh von Schmeeddaniels Hof. Faktisch kommen damit deutlich über 100 MBit/s an.

Von besonderer Bedeutung im Kirchturm ist das Gerät FF-Mellnau-Kirche-ERX. An seinen Ports hängen in dieser Reihenfolge:

  1. DLAN (=>Accesspoint FF-Mellnau-Kirche)
  2. Accesspoint FF-Mellnau-Kirchturm
  3. Nanostation 87 (UNMS)
  4. Nanostation 88 (UNMS)
  5. Nanostation 31 (UNMS)

Diese Portbelegung wird benötigt, falls an FF-Mellnau-Kirche-ERX einmal die /etc/config/network angepasst werden muss.

Perspektivisch ist der Kirchturm jetzt soweit vorbereitet, dass am Turm WLAN abgeholt werden kann. Sowohl für das Wattenscheider Lager als auch Richtung Wetter sind interessant Perspektiven möglich.

Das Gerät FF-Mellnau-Kirchturm läuft im Outdoor-Modus.

ToDo: Gerät 31 wurde irrtümlich mit einem CAT5 Kabel ausgestattet, wodurch der Durchsatz auf 100 MBit/s begrenzt ist. Muss bei passender Gelegenheit geändert werden.

Kuckuckshütte

In der Kuckuckshütte befinden sich die Geräte FF-Mellnau-ERX-Kuckuckshütte und FF-Mellnau-Kuckuckshuette. Der ERX hängt topologisch hinter einem Speedport-Router und ist mit 25 MBit/s angebunden. Hinter dem ERX hängt ein Standard-Accesspoint, der gleichzeitig als Funkbrücke zu FF-Mellnau-Burg2 dient.

Die technischen Gerätschaften finden sich allesamt hinter dem Fernseher in der Kuckuckshütte. Dort ist auch noch ein Switch angebracht, so dass das Freifunk-Netz neben dem Pay-TV Reciever existieren kann.

Der ERX in der Kuckuckshütte ist eigentlich überdimensioniert. Sollte jedoch einmal das Internet in der Grundschule ausfallen, wäre hier ein potent angebundener Netzknoten, der den Ausfall zumindest teilweise übernehmen könnte – wenn auch die Mesh-Anbindung zur Burg in diesem Fall eher hinderlich wäre. Im Normalfall führt dieser ERX einfach nur dazu, dass sich das Freifunknetz in der Kuckuckshütte etwas schneller anfühlt als an Standorten ohne Offloader.

ToDo 2019: Da der Accesspoint nur innerhalb der Kuckuckshütte genutzt wird, könnte er durch ein Tischgerät ersetzt werden. Dadurch würde ein weiterer outdoortauglicher Accesspoint frei werden.

Owe Feisels Hof

Ursprünglich war der Plan, von Owe Feisels Hof aus die Bushaltestelle im Unterdorf zu erreichen. Das klappte zwar nicht – doch der Jugendclub profitiert von diesem Anschluss. Da der Hof sehr tief liegt, ist in Sachen Richtfunk nicht viel zu machen – von daher hat es bisher erst ein Accesspoint an die Fassade geschafft. Er läuft im Outdoor-Modus.

Wanderparkplatz

Der Accesspoint FF-Mellnau-Wanderparkplatz hängt an der Garage der Familie Feike. Das Gerät ist per DLAN an einen Speedport  mit 25 MBit/s angeschlossen. Da das Gerät gedreht zum Wanderparkplatz steht, kommen das WLAN dort mit einer Signalstärke von 2 Balken an. Speedtests von der Bank aus zeigen dennoch 18 MBit/s an. Das genügt. Da der Wanderparkplatz sehr weit draußen ist, ist das Gerät bisher das einzige, das geplant “unvermesht” in Mellnau ist. Weitere Netzspender aus dem Bereich Alte Höhle sind willkommen.

Wattenscheider Lager

Schaltschrank Nummer 1

Das Ferienlager in Mellnau, auch Wattenscheider Lager genannt, ist ein Ferienheim und Zeltlager, mitten im Wald gelegen. Die Erschließung dieser Location mit WLAN ist Teil eines eigenen Artikels – hier soll sich auf die harte Technik beschränkt werden.

Dreh- und Angelpunkt der Freifunk-Technik im Wattenscheider Lager ist der Balkon. Dort finden sich zwei kleine Schaltschränke, in denen die LAN-Verkabelung des Lagers zusammenkommt. Der rechte Schaltschrank beinhaltet die Verkabelung für die Accesspoints am Hauptgebäude sowie für die drei Geräte am Gästehaus Richtung Dorf. Im linken Schrank kommen die Kabel für den unteren Teil des Lagers sowie für die Richtfunktechnik Richtung Sportplatz zusammen.

Im hinteren Teil des Balkons unter der Decke befindet sich der Accesspoint FF-Mellnau-Ferienlager3. Der Accesspoint FF-Mellnau-Ferienlager1 befindet sich im Hauptgebäude im Eingangsraum auf einem Schrank. Er hat keinen direkten Kabelanschluss an den zentralen ERX, da sich aus dem Hauptgebäude heraus noch kein Kabelweg in den Schaltschrank gefunden hat.

2 Richtfunkantennen und 1 Accesspoint am Gästehaus

Am Gästehaus befindet sich der Accesspoint FF-Mellnau-Ferienlager2. Er wird flankiert von zwei Richtfunkgeräten, einer 5 GHz Strecke in den Kirchturm sowie einer 2,4 GHz Strecke Richtung Stöcke (Wehn-Wagenhäuser). Alle drei Geräte kommen im Schaltschrank 1 am Gerät FF-Mellnau-Ferienlager-ERX zusammen.

Links im Bild sieht man die 2,4 GHz Bridge Richtung Stöcke (Wagenhäuser-Wehn). Rechts im Bild den 5GHz Uplink zum Kirchturm. Die Richtfunkstrecke zum Kirchturm muss jedes Jahr einmal freigeschnitten werden – diese Aufgabe obliegt dem Ferienlager. Da die Antenne etwas hervorragt, wurde sie sicherheitshalber geerdet.

Hinter der Holzverkleidung kommen die Kabel aus Schaltschrank 1 auf einem Patchfeld zusammen. Die daraus kommenden Kabel wurden in einem Elektroverzweigerkasten an der Holzfassade zusammengeführt. Sollte es einmal nötig sein, ließen sich diese Kabel leicht ersetzen.

ToDo: Am ERX des Ferienlagers ist die VLAN-Trennung noch nicht aktiviert. Das führt dazu, dass auf der Freifunk Map die Verbindungen Richtung Wehn-Wagenhäuser etwas irreführend angezeigt werden.

Zum Teil musste im Ferienlager “fliegend verkabelt” werden.

In den unteren Teil des Ferienlagers mussten zum Teil recht unkonventionelle Kabelwege genommen werden, um zwischen den Waldhütten und Bäumen einen Weg zu finden. Unklar ist, inwieweit das normale Verlegekabel im Wald durch UV-Strahlung beschädigt werden kann.

Mit der Verkabelung wurde die Grundlage dafür geschaffen, zu einem späteren Zeitpunkt den Sportplatz sowie den unteren Teil des Ferienlagers WLAN-mäßig erschließen zu können.

ToDo: im Auge behalten.

Wehn & Wagenhäuser

Accesspoint und Richtfunkgerät

Im ehemaligen Neubaugebiet in den Stöcken beherbergt die Familie Wehn-Wagenhäuser die Accesspoints FF-Mellnau-Wehn und FF-Mellnau-Wagenhaeuser. Darüber hinaus ist bei ihnen auch eine Richtfunkantenne Richtung Wattenscheider Lager angebracht. Der Standort ist besonders spannend, da er auch bei relativ dichtem Bewuchs im Sommer zwei zuverlässige Verbindungen zum Wattenscheider Lager herstellen kann – und zwar sowohl über 2,4 GHz Richtfunk als auch über den Wagenhäuser Accesspoint. Darüber hinaus verbindet sich der Wagenhäuser-AP auch direkt mit der Installation im Kirchturm – so dass er selbst dann Daten liefern kann, falls der Hausanschluss der Wehn-Wagenhäusers einmal ausfallen sollte.

Das Gerät FF-Mellnau-Wehn dient lediglich der Anbindung des Wagenhäuser-APs ans Internet. Eine Verbindung über DLAN war aus verschiedenen Gründen hier nicht sinnvoll machbar.

Die Outdoor-Geräte hängen alle am Carport, das Indoor-Gerät steht im Obergeschoss im Büro. Die Netzteile der Outdoor-Geräte hängen im hinteren Teil des Carports links hinter der Tür.

Unversorgte Stellen in Mellnau

An folgenden Plätzen und Orten sollte Freifunk noch installiert werden:

  • Bushaltestelle im Unterdorf (*)
  • Sportlerheim
  • Sitzbank an der Alte Höhle

Um hier Freifunk installieren zu können, werden noch Anwohner gesucht, die einen Accesspoint bei sich aufnehmen und im Optimalfall auch ihre Internetleitung hierfür zur Verfügung stellen. Die benötigte Technik und Montage wird von der Mellnauer Vereinsgemeinschaft gestellt. Wer unser Freifunk Netzwerk unterstützen möchte oder Bedarf an weiteren Hotspots im Ort sieht, meldet sich per E-Mail an Freifunk@mellnau.de.

(*) Hier hat sich bereits eine Herberge gefunden, Montage ist in Planung

Wissenswertes zu den Freifunk-Standorten in Oberrosphe

Seit Oktober 2020 gibt es auch Freifunk-Accesspoints nach dem Mellnauer Konzept in Oberrosphe. Die Site-spezifischen Besonderheiten finden sich hier.

Pfarramt

Das Pfarramt ist mit ca. 50 MBit/s angebunden. Hinter dem hauseigenen Router hängt ein Ubiquiti ERX. Dieser versorgt per PoE eine an der Fassade befindliche Nanostation Loco 5AC (Gerät #59). Über sie wird eine Funkbrücke in den Kirchendachstuhl hergestellt. Auf Port 4 des Routers wird sowohl MoL als auch das getaggte VLAN 5 übertragen. VLAN 5 wird für das Management Interface der Nanostations genutzt.

Kirchendachstuhl

Blick auf die Installation

Im Dachstuhl der Kirche in Oberrosphe findet sich der Accesspoint FF-Oberrosphe-Kirchturm sowie Richtfunkgerät #58 für die Funkbrücke zum Pfarramt. Der ursprüngliche Plan war, den Accesspoint ganz oben im Glockenturm aufzuhängen. Insbesondere mangels Platz lies sich das so nicht umsetzen, so dass beide Geräte nun auf der Plattform zwischen dem Dachboden und dem Kirchturm installiert sind. Bemerkenswert ist hier noch, dass die Nanostation ohne Sichtkontakt zum Pfarramt ist, dennoch aber über 40 MBit/s netto im Dachstuhl ankommen.

Gemeindehaus

Im Gemeindehaus der Kirche befindet sich zwar ein passwortgeschütztes Gastnetz, es sollte dort auf Wunsch der Kirche aber ebenfalls Freifunk erhältlich sein. Provisorisch wurde dort zunächst ein kleiner 841’er Accesspoint aufgestellt, der aber im Speedtest auf rund 13 MBit/s kommt und im Tagungsraum mit voller stärke empfangbar ist. Die Anbindung wurde testweise über DLAN zum Pfarramt versucht, was aber nicht gelang. Aktuell erfolgt der Kontakt lediglich über den Kirchturm. Es wäre hilfreich, wenn noch ein oder zwei Anwohner im Umfeld der Kirche bei Freifunk mitmachen würden.

ToDo: im Auge behalten, ob das Gerät leistungsfähig genug ist. 

Unversorgte Stellen in Oberrosphe

An der Grundschule soll noch Freifunk nachgezogen werden, am DGH in Oberrosphe gibt es bereits Freifunk. Von Seiten des Ortsbeirats Oberrosphe erreichte uns die Nachricht, dass eine weitergehende Versorgung im Ort nicht gewünscht ist. Die L(i)ebenswertes Rosphetal GbR (aka “die Stiftung”) stellt grundsätzlich Material und Know-How für weitere Accesspoints bereit, will aber auch keinen Streit im Ort verursachen. Interessenten können sich gerne bei freifunk@mellnau.de melden.

Wissenswertes zu den Freifunk-Standorten in Unterrosphe

Gemeindehaus

Im Gemeindehaus Unterrosphe steht ein kleiner Indoor-Freifunk-Router, FF-Unterrosphe-Gemeindehaus. Er wird per Mesh versorgt vom Kirchturm und von Schmeeds Hof.

Göbelers

Powerbeam Richtung Mellnau

Das Haus der Familie Göbeler ist für das Unterrospher Freifunknetz von zentraler Bedeutung. Dankenswerterweise befindet sich hier zunächst einmal ein vollwertiger Internetanschluss, der über DLAN den Accesspoint FF-Unterrosphe-Goebelers1 versorgt. Von dort wird FF-Unterrosphe-Goebelers2 per Mesh angebunden, der das Signal wiederrum an FF-Unterrosphe-Goebelers-ERX weitergibt. Accesspoint Nummer 1 ist im Obergeschoss im Badezimmer, Accesspoint 2 und der ERX im ehemaligen Kaninchenstall. Am ERX hängt eine Nanostation Richtung Tennisheim sowie eine große Powerbeam Richtung Mellnau. Letztere funkt direkt zu FF-Mellnau-Dorfrechenzentrum, erstere zu FF-Unterrosphe-Tennisheim-ERX. Per DLAN direkt in den Kaninchenstall zu gehen, hat sich leider als unstabil erwiesen.

Die Elektronik im Kaninchenstall ist in einer wetterfesten Box nahe der Tür untergebracht. Der Zugang dahin ist mitunter etwas schwierig, da der Stall auch gerne mal als Holzlager genutzt wird. Im Zweifelsfall lohnt es sich, vorher anzurufen, wenn wirklich Zugang zur Kiste benötigt wird.

Der Uplink nach Mellnau ist leider recht bodennah, kaum 1,5 Meter über dem Boden. Und leider kreuzt auch ein Bäumchen die Fresnel Zone. Der Uplink funktioniert zwar, ist aber nicht so stabil, wie man es sich wünschen würde. Es fehlt an Höhe und freier Schussbahn – ist aber besser als nichts.

Der Link zum Tennisheim hängt auf derselben Höhe, hat aber relativ freie Sicht aufs Tennisheim – zumindest auf Göbelers Seite. Vorm Tennisheim sieht das schon wieder anders aus, mehr dazu an entsprechender Stelle.

Kirche

Ubiquiti ERX SFP in der Kirche in Unterrosphe

Unter dem Dach der Kirche befindet sich ein zentraler Teil der Unterrospher Freifunkinstallation. Es findet sich dort FF-Unterrosphe-Kirche-ERX, an dem das Richtfunkgerät Richtung Schmeeds Hof sowie FF-Unterrosphe-Kirche hängen.

Neben diesen beiden Geräten sind noch zwei weitere Richtfunkgeräte mit dem ERX verbunden – sie sind zur Zeit aber leider nicht in Betrieb, siehe Kirchturm.

Die Installation unter dem Kirchendach ist insofern auch bemerkenswert, als das hier sowohl über Richtfunk als auch per Mesh Internet von Schmeeds Hof geholt wird. Als zentraler Verteiler ist der Kirchturm gut nutzbar – es fehlen jetzt nur noch ein paar mehr angeschlossene Geräte.

Kirchturm

Ubiquiti Powerbeam 5 AC Gen2 Richtung Mellnau

In der Kirchturmspitze befinden sich zwei Richtfunkgeräte, die an den ERX unter dem Kirchendach angeschlossen sind. Es handelt sich um einen Ubiquiti NBE 5AC Gen. 2 Richtung Mellnau sowie um eine ältere Nanostation M2 loco Richtung Sportplatz.

Erstaunlicherweise kommt an der 5AC Schüssel kein brauchbares Signal an. Weder aus Mellnau noch innerhalb des Dorfes vom Haus Göbeler – was überaus erstaunlich ist, denn das Gerät ist nur einen Steinwurf von der Kirche entfernt und hat direkte Sicht. Es kann sein, dass das Gitter vor dem Kirchturmfenster hier ganze Arbeit leistet. So oder so, es passiert nichts.

Ähnlich verhält es sich mit der Nanostation M2 loco. Sie sollte eigentlich bis zum Sportplatz durchkommen, doch auch dort ist nichts von dem Signal zu hören. Beide Geräte sind dennoch “auf Empfang” gelassen worden, da die Hoffnung besteht, in Unterrosphe noch ein paar weitere Teilnehmer für das Netz gewinnen zu können.

Schmeeds Hof

Frank Erkel war der erste in Unterrosphe, der Freifunk im Außenbereich bei sich am Hof aufstellte. Über seinen Hof wird die angrenzende Kirche und das Gemeindehaus versorgt.

Vom Gerät FF-Unterrosphe-Schmeeds-Hof-ERX aus gibt es einen Richtfunk-Uplink in die Kirche. Außerdem mesht der am Hof befestigte Accesspoint FF-Unterrosphe-Schmeeds-Hof mit den Geräten im Kirchturm und Gemeindehaus.

Die Freifunk-Geräte stehen allesamt im Obergeschoss bzw. hängen an der dortigen Fensterfront. Der ERX ist per DLAN mit dem Router im Erdgeschoss verbunden.

Stiftung Rosphetal

Im Wintergarten der Familie Müller direkt an der Kreisstraße steht das Gerät FF-Unterrosphe-Stiftung-Rosphetal. Werner Müller und Gattin Barbara haben persönlich sehr viel dazu beigetragen, dass das Freifunk-Netz in der Region diesen Ausbaustand hat. Da ist es Ehrensache, dass sie natürlich auch einen eigenen Accesspoint beherbergen. Mesh-Partner für den Accesspoint werden noch gesucht.

Tennisheim

ERX mit DLAN und 2x Richtfunk im Tennisheim

Die Installation am Tennisheim in Unterrosphe besteht aus den Geräten FF-Unterrosphe-Tennisheim-ERX sowie FF-Unterropshe-Tennisheim1 und FF-Unterrosphe-Tennisheim2. Der ERX hängt im an der Wand im Kelleranbau. An ihm hängt per Kabel Tennisheim2 sowie eine Powerbeam-Richtfunkantenne Richtung Goebelers.

Die Richtfunkantenne ist bewusst größer dimensioniert, da sie durch starken Bewuchs durch muss. Sinnvollerweise sollte der Bewuchs einmal im Jahr vom Verein deutlich zurückgeschnitten werden. Das Gerät Tennisheim1 ist per DLAN und Mesh via Tennisheim2 mit dem ERX verbunden.

Unversorgte Stellen in Unterrosphe

In der nächsten Zeit soll der WLAN-Ausbau in Unterrosphe angegangen werden. Auf dem Plan stehen:

  • der Sportplatz
  • der Festplatz
  • der Beachvolleyballplatz
  • mehr WLAN im Umfeld des Tennisclubs

Damit das alles klappt, werden insbesondere um den Beachvolleyplatz noch Netzzugangsspender gesucht. Interessenten melden sich bitte bei Jan Phillip Schröder in Unterrosphe oder wenden sich per Mail an freifunk@mellnau.de.

Wissenswertes zu den Freifunk-Standorten in Wetter (Hessen)

Im Dezember 2020 kamen die ersten Freifunk-Hotspots in der Kernstadt an. Mehr dazu in Kürze.

Ärztehaus

Das Gerät FF-Wetter-Ärztehaus hängt an der Fassade gegenüber vom Baccos. Es verfügt über einen 25 Mbit/s Anschluss, der jedoch aus Sicherheitsgründen gedrosselt ist – etwas Haustechnik hängt auf derselben Leitung. Der Anschluss wird gestellt von der HBH Telemedia AG.

Nienhaus

Im Garten der Familie Nienhaus im Eisenacher Weg hängt eine Powerbeam Antenne (Gerät #81) Richtung Mellnau. Dahinter befindet sich FF-Wetter-Nienhaus-SPD-ERX, der neben dem Uplink nach Mellnau auch per DLAN mit dem heimischen Router sowie mit FF-Wetter-Nienhaus-SPD verbunden ist. Ähnlich wie auch in der Grundschule Mellnau scheint das DLAN (Devolo 1200er) nur unstabil zu laufen, jedenfalls bezieht der Accesspoint sein Internet gelegentlich nur über Mellnau und nicht über den heimischen Router.

ToDo: ggf. das DLAN durch einen Indoor-Router ersetzen, vergleichbar der Kombination Wehn-Wagenhäuser.

Unversorgte Stellen in der Kernstadt

Die Kernstadt steht noch ganz am Anfang der Freifunk-Entwicklung, von daher wird hier überall noch WLAN benötigt. Offensichtlich anbieten würde es sich u.a. hier:

  • Rund um den Bahnhof und die dortige Bushaltestelle
  • In Wetters neuer Mitte
  • Zwischen Bullenstall und Sporthalle
  • Rund um die ehemalige Synagoge (Veranstaltungslocation)

Freifunk und die übrigen Stadtteile von Wetter

Den eigenen Internetanschluss mit der Gemeinschaft zu teilen und damit ein Community-Netz aufzuspannen, ist grundsätzlich auch in den übrigen Stadtteilen machbar. Letztlich kommt es darauf an, ob sich ein Verein oder Privatmensch findet, der die nötige Technik bezahlt – wir reden hier von ein paar hundert Euro einmaliger Kosten pro Location. Wenn es dann noch ein paar helfende Hände gibt, kann es voran gehen. Interessenten wenden sich vertrauensvoll per E-Mail an andreas.ditze@mellnau.de.